Featured Image missing in WordPress 3.2 Admin

I’ve just upgraded from 3.1.2 to 3.2, and now “featured image” is no longer listed at the bottom right of a post in admin.

Has this feature of WP been removed?

Can it be added back, or turned back on?

My old posts still have their old featured image, but it cannot be added to new ones.

Solutions Collecting From Web of "Featured Image missing in WordPress 3.2 Admin"

For me, “Featured Image” was still missing from the Screen Options tab, even after clearing the cache and restarting the browser. In my case the problem was related to having a WordPress 3.2 Multisite install. With this setup, the Media upload buttons must be checked in Network Admin to enable the featured image meta box in the editor (these are unchecked by default). From the WordPress Codex:

To show the “Featured Image” meta box in mulsite installation, make sure you update the allowed upload file types, in Network Admin, Network Admin Settings SubPanel, Upload Settings, Media upload buttons options. Default is off.

Have you looked in the Screen Options tab (top right on the Add Post / Edit Post page) to make sure ‘Featured Image’ is checked? It may not be set to show up by default but it should be there. Once you’ve checked the box it will remember your preferences.

You have to put following code in the functions.php

add_theme_support( 'post-thumbnails', array( 'post', 'page' ) ); // Add it for posts

I had to restart my browser, and after logging back into admin featured image has reappeared. I made no changes to settings.

Add this to your functions.php:

<?php the_post_thumbnail();?>

If its still not working, go further with these steps:
http://www.blog.web6.org/wordpress-3-0-set-featured-image/