Images not showing after moving site (but path id OK)

I moved (actually copied) a WordPress site (http://inglesen100dias.com/) to a new server and domain (http://blog.inglesen100dias.com/).

I followed the process described on WordPress’ website and also used a search and replace script as recommended there to fix the path of the images, so they use the new URL of the site.

Everything seems fine except the images, which they don’t show (as you can see if you click in both links above). But looking at the path of the images, it seems to be fine, and even if I copy that path and paste it in the browser the image shows fine, but it doesn’t when looking at the website.

I’ve also removed the .htaccess file but nothing is working.

Does anyone have ideas how I can get the images to work?

Solutions Collecting From Web of "Images not showing after moving site (but path id OK)"

I’ll post the answer to my problem, which I got thanks to the links provided by Jesse. What I did was to delete the index.html and .touch files form the cache folder where the tinthumb.php file is located. After that it all worked perfectly!

This is the error I get when trying to view any image directly:

Warning: touch() [function.touch]: Utime failed: Permission denied in
/home/columbia/public_html/wordpress/inglesen100dias/wp-content/themes/motionpicture/functions/timthumb.php
on line 200

Warning: touch() [function.touch]: Utime failed: Permission denied in
/home/columbia/public_html/wordpress/inglesen100dias/wp-content/themes/motionpicture/functions/timthumb.php
on line 469

Warning: Cannot modify header information – headers already sent by
(output started at
/home/columbia/public_html/wordpress/inglesen100dias/wp-content/themes/motionpicture/functions/timthumb.php:200)
in
/home/columbia/public_html/wordpress/inglesen100dias/wp-content/themes/motionpicture/functions/timthumb.php
on line 418 A TimThumb error has occured

The following error(s) occured: Could not create the index.html file –
to fix this create an empty file named index.html file in the cache
directory. Could not create cache clean timestamp file.

Query String :
src=http://img.mywordpresstips.com/images/1072482_79445869.jpg&w=195&h=120&zc=1&f=
TimThumb version : 2.8.11

A quick search found these two results:

  • WordPress Error: A TimThumb error has occured
  • Timthumb can’t show image after it’s uploaded