What are the issues associated with upgrading MySQL for WordPress?

What are the issues associated with upgrading MySQL from 5.1 up to 5.5 for a server hosting multiple WordPress sites?

Will there be problems with the database after the upgrade?

I have Plesk 12 installed on a Ubuntu server and I can update to the latest version of MySQL (I believe only 5.5) but I don’t know if this will cause issues? Is upgrading MySQL straightforward in terms of database compatibility (upgrading 5.1 to 5.5) or is it likely that things will break?

Solutions Collecting From Web of "What are the issues associated with upgrading MySQL for WordPress?"

It depends on what version of WordPress your sites run. If you are up to date, you shouldn’t have much of an issue. According to the official WordPress hosting guide, any version of MySQL version 5.0.15 or greater is supported for WordPress. You can give this article a read and see if there is anything that jumps out at you as being particularly dangerous.

If you are running a version of WordPress that is very old you are more likely to run into issues; however, if you are running a version that old you should strongly consider upgrading WordPress regardless.

That said, there can always be issues with this type of upgrade and if you decided to go forward with it you should make sure you have backups of everything. If WordPress compatibility is your only concern you should be ok. If this is for a production environment, I would strongly suggest testing both the upgrade and your sites on a dev server rather than doing a live in-place upgrade.