WordPress plugin compatibility explaination when wordpress releases its new version (theoretical)

Recently i updated my wordpress to its latest version 3.4.1 and noticed that few of my plugins are only compatible upto 3.3 although they are working correctly for my site even with the latest version.

So does that means that i need to disable those plugins and look for the alternatives and these plugins are no more SAFE to use or it is something else( i downloaded all plugins from wordpress.org ONLY) .

Need a better clarification over this and let me know if some concept i m missing with the up gradation 🙂 . Detailed answer is really appreciated and i will do my part then 🙂

Solutions Collecting From Web of "WordPress plugin compatibility explaination when wordpress releases its new version (theoretical)"